Minimum System Requirements

We only deploy QuickWatch on supported machines. However, from time-to-time our requirements change. Like when Microsoft ended support for Windows XP, we also ended support for QuickWatch users with Windows XP machines at the same time.

When these requirements change, we will alert all QuickWatch users on our monthly mailing list and update this page. If you currently get monthly updates via our newsletter, then you will see if these requirements change. If you are not on the list, please contact us so we can add you.

These requirements are important. If your machine does not meet the minimum requirements, then we can’t offer the guarantees that we do everyone else. For instance, if you are using Windows XP, we do not offer a free disinfection if you are infected. This is because Windows XP is very unsafe for users and all XP users have been warned many times to stop using this operating system.

In short, if your computer is older or slower than this list, then we would be doing you a disservice by putting QuickWatch on your computer… and we don’t want that. We only aim to please! Get a new system and let us make it safe!

PC

  • Currently supported and updated version of Windows
  • Core i5 3000 processor or greater
  • 8 GB RAM or more (16 GB is recommended)
  • 7200 RPM HDD or faster (SDD = way better and highly recommended)
  • 1.0 Mbps upload or greater (if backup is needed)

Mac

  • Currently supported and updated version of macOS
  • Core i5 3000 processor or greater
  • 8 GB RAM or more (16 GB is recommended)
  • 7200 RPM HDD or faster (SDD = way better and highly recommended)
  • 1.0 Mbps upload or greater (if backup is needed)

Server

  • True server build (no workstations running a server OS)
  • Windows Server 2008+ (with current updates)
  • Most Linux server distros (call us to talk to an engineer)
  • 16 GB RAM (unused)
  • Xeon E3-12 series and above processors
  • 2.0 Mbps upload or greater (if backup is needed)